Degraded performance due to issues on our hosting provider AWS
Incident Report for Frontify
Resolved
Frontify page speed is back to normal.
Posted Dec 07, 2021 - 21:49 UTC
Monitoring
As AWS services are starting to resume the Frontify performance is increasing.
Posted Dec 07, 2021 - 19:59 UTC
Investigating
We can see slower response times for specific requests. These issues are related to the issues our infrastructure and services provider AWS is facing.
Posted Dec 07, 2021 - 17:49 UTC
This incident affected: Frontify Enterprise Application - DataCenter US and Frontify SelfService Application - DataCenter US.