Asset processing and delivery broken for some assets

Incident Report for Frontify

Resolved

After AWS reported that all issues had been resolved, we were able to migrate the delivery and processing of assets back to the US for US hosted customers this morning.
Posted Oct 21, 2025 - 08:13 UTC

Identified

Due to an Amazon Web Services outage, we are temporarily routing the delivery and processing of assets in the Americas via Europe. If you have any concerns, please contact legal@frontify.com
Posted Oct 20, 2025 - 15:37 UTC
This incident affected: Frontify Enterprise Application - DataCenter US.