Partial outage due to AWS issue - SelfService

Incident Report for Frontify

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 18:22 UTC

Update

We are continuing to monitor for any further issues.
Posted Oct 20, 2025 - 18:21 UTC

Update

All uploaded assets are processed and should show and search results are up-to-date as well.
Posted Oct 20, 2025 - 18:20 UTC

Update

The service is running and catching up with the queue. The search should start showing new content.
Posted Oct 20, 2025 - 18:08 UTC

Monitoring

Our SelfService application is still affected by the ongoing AWS issue in the US region, preventing us from launching new servers. This may cause slower processing or temporary outages, mainly in image processing and search.

Newly uploaded assets may not appear. AWS is working to resolve the issue.
Posted Oct 20, 2025 - 14:18 UTC
This incident affected: Frontify SelfService Application - DataCenter US.