Degraded Performance

Incident Report for Frontify

Resolved

This incident has been resolved.
Posted Mar 12, 2026 - 15:07 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 12, 2026 - 15:04 UTC

Identified

We are currently experiencing degraded performance on the Self-Service environment.

Our team is actively investigating the root cause and working to restore stability as quickly as possible. At this stage, the impact is limited to the Self-Service environment; Enterprise customers remain operational.
Posted Mar 12, 2026 - 14:34 UTC
This incident affected: Frontify SelfService Application - DataCenter US.