Degrated Performance

Incident Report for Frontify

Resolved

This incident has been resolved.
Posted Feb 14, 2019 - 07:16 UTC

Update

We are continuing to monitor for any further issues.
Posted Feb 14, 2019 - 07:15 UTC

Monitoring

Due to an AWS outtage we encounter degrated performance on the Frontify Application and Website
Posted Feb 14, 2019 - 07:14 UTC
This incident affected: Frontify Website and Frontify SelfService Application - DataCenter US.